[perlメモ]LWP::Protocol::httpsモジュールインストール時のエラー

CPANでLWP::Protocol::httpsをインストールしようとしたら以下のようなエラーになった。

 

SULLR/IO-Socket-SSL-1.44.tar.gz              : make_test NO one dependency not OK (Net::SSLeay); additionally test harness failed
GAAS/LWP-Protocol-https-6.02.tar.gz          : make_test NO one dependency not OK (IO::Socket::SSL); additionally test harness failed

LWP::Protocol::httpsの依存モジュールIO::Soket-SSLモジュールがコンパイル出来ずにエラー。そのIO::Soket-SSLモジュールは依存モジュールNet:SSLeayがコンパイル出来なくてエラー。

Net::SSLeayはOpenSSLを使うためのモジュールらしいので例によってdevelが入ってないのだろうと予想。

# yum info openssl-*

yumのinfoコマンドで確認してみると以下のようになりopenssl-develは未インストールだった。

[root@rad-xen-vweb7 httpd]# yum info openssl-*
Loaded plugins: downloadonly, fastestmirror
Loading mirror speeds from cached hostfile
* base: ftp.iij.ad.jp
* extras: ftp.iij.ad.jp
* updates: ftp.iij.ad.jp
Installed Packages
Name       : openssl
Arch       : i686
Version    : 0.9.8e
Release    : 12.el5_5.7
Size       : 3.3 M
Repo       : installed
Summary    : The OpenSSL toolkit
URL        : http://www.openssl.org/
License    : BSDish
Description: OpenSSL ツールキットはマシン間の安全な通信をサポートします。OpenSSL
           : には、証明書管理ツールと、各種の暗号化アルゴリズムとプロトコルを提供する
           : 共有ライブラリが含まれています。

Available Packages
Name       : openssl
Arch       : i386
Version    : 0.9.8e
Release    : 12.el5_5.7
Size       : 1.4 M
Repo       : base
Summary    : The OpenSSL toolkit
URL        : http://www.openssl.org/
License    : BSDish
Description: OpenSSL ツールキットはマシン間の安全な通信をサポートします。OpenSSL
           : には、証明書管理ツールと、各種の暗号化アルゴリズムとプロトコルを提供する
           : 共有ライブラリが含まれています。

Name       : openssl-devel
Arch       : i386
Version    : 0.9.8e
Release    : 12.el5_5.7
Size       : 1.9 M
Repo       : base
Summary    : Files for development of applications which will use OpenSSL
URL        : http://www.openssl.org/
License    : BSDish
Description: OpenSSL は暗号をサポートするためのツールキットです。openssl-devel
           : パッケージには各種の暗号化アルゴリズムとプロトコルをサポートした
           : アプリケーションを開発するために必要な静的ライブラリとヘッダーファイルが
           : 含まれています。

Name       : openssl-perl
Arch       : i386
Version    : 0.9.8e
Release    : 12.el5_5.7
Size       : 35 k
Repo       : base
Summary    : Perl scripts provided with OpenSSL
URL        : http://www.openssl.org/
License    : BSDish
Description: OpenSSL は暗号をサポートするためのツールキットです。openssl-perl パッケージは、
           : 他の形式の証明書と鍵を OpenSSL ツールキットで使われる形式に変換する
           : ための Perl スクリプトを提供します。

[root@rad-xen-vweb7 httpd]# yum install openssl-devel

 

#yum install openssl-devel

上記のコマンドでopenssl-develをインストール後にLWP::Protocol::httpsモジュールをCPANから再度インストールしてみたら正常にインストールすることができた。

(Visited 17 times, 1 visits today)

タグ : , , ,