DAEMON Tools 4.09をインストールしようとするとInternal setup errorになる件について

無料の仮想CD/DVDソフトの大御所Daemon toolsですが、久々にバージョンアップでもしてみようかと思ってサイトを見に行ってみたらVersion.4.09が出ていたのでさっそくアップデートすることにしました。
ところがインストールしようとすると「Internal setup error. Contact suppor」というエラーが出てしました。これを解決するまでのお話です。


DAEMON Toolsの配布元から最新版のDAEMON Tools 4.09 X86をダウンロードしました。
ダウンロードしたファイルは
daemon4091-x86.exe
でした。実行してインストールを進めると
「Internal setup error. Contact suppor」というエラーがでてインストールが出来ずに終了してしまいます。
一度PCを再起動してから試してみましたがだめでした。
インターネットで検索してみるとDAEMONTOOLSのサポートフォーラムが見つかりました。
フォーラムは英語なので内容はよくわかりませんが(おい)
SPTD(SCSI Pass Through Direct)の最新版をインストールしてからインストールすればOKみたいな事が書いてあるようです。w
そういえばDaemon toolsのダウンロードページにも「UPDATED VERSION!! SPTD1.43 INCLUDED!」と書いてあった。
そういうわけでSPTDのダウンロードページからSPTDのの最新版をダウンロードしました。
ダウンロードしたSPTDのバージョンは1.50でファイル名は
SPTDinst-v150-x86.exe
でした。
SPTDinst-v150-x86.exeを実行してインストールしようとすると古いバージョンがあるのでアンインストールするかアップデートするか表示されます。僕はとりあえず安全にアンインストールしました。PCの再起動をしろと言われるので再起動後再びSPTDinst-v150-x86.exeを実行してインストール完了。更に再起動しろと言われるのでPCを再起動。
その後daemon4091-x86.exeを実行してインストールを開始するとエラーも無くすんなりインストールすることが出来ました。

※注意:
最近はどうなってるのか知りませんが、Daemon Toolsはバージョン4.0以降スパイウェアが入っているので「DAEMON Tools Search Bar」のチェックは外してインストールするのが常識ですのでインストール時にインストールファイルの選択画面では必ず「DAEMON Tools Search Bar」のチェックを外してからインストールを行ってください。

▼DAEMON Toolsの配布元(英語)
http://www.daemon-tools.cc/
▼DAEMONTOOLSのサポートフォーラム(英語)
http://www.daemon-tools.cc/dtcc/daemon-tools-4-09-internal-t17276.html
▼SPTDのダウンロードページ
http://www.duplexsecure.com/en/downloads

タグ :